borgend.spec

Sun, 05 Dec 2021 14:39:41 +0200

author
Tuomo Valkonen <tuomov@iki.fi>
date
Sun, 05 Dec 2021 14:39:41 +0200
changeset 136
c40f341a99e0
permissions
-rw-r--r--

Add borgend.spec for PyInstaller as an option.

# -*- mode: python ; coding: utf-8 -*-

block_cipher = None

a = Analysis(['borgend/__main__.py'],
             pathex=[],
             binaries=[],
             datas=[],
             hiddenimports=[],
             hookspath=[],
             hooksconfig={},
             runtime_hooks=[],
             excludes=[],
             win_no_prefer_redirects=False,
             win_private_assemblies=False,
             cipher=block_cipher,
             noarchive=False)
pyz = PYZ(a.pure, a.zipped_data,
             cipher=block_cipher)

exe = EXE(pyz,
          a.scripts, 
          [],
          exclude_binaries=True,
          name='borgend',
          debug=False,
          bootloader_ignore_signals=False,
          strip=False,
          upx=True,
          console=False,
          disable_windowed_traceback=False,
          target_arch=None,
          codesign_identity=None,
          entitlements_file=None )
coll = COLLECT(exe,
               a.binaries,
               a.zipfiles,
               a.datas, 
               strip=False,
               upx=True,
               upx_exclude=[],
               name='borgend')
app = BUNDLE(coll,
             name='borgend.app',
             icon=None,
             bundle_identifier=None)

mercurial