Cargo.toml

branch
dev
changeset 35
b087e3eab191
parent 30
bd13c2ae3450
child 39
6316d68b58af
--- a/Cargo.toml	Thu Aug 29 00:00:00 2024 -0500
+++ b/Cargo.toml	Tue Dec 31 09:25:45 2024 -0500
@@ -21,29 +21,31 @@
 ]
 categories = ["mathematics", "science", "computer-vision"]
 
+[dependencies.alg_tools]
+version = "~0.3.0-dev"
+path = "../alg_tools"
+default-features =  false
+features = ["nightly"]
+
 [dependencies]
-alg_tools = { version = "~0.2.0-dev", path = "../alg_tools", default-features = false }
 serde = { version = "1.0", features = ["derive"] }
 num-traits = { version = "~0.2.14", features = ["std"] }
 rand = "~0.8.5"
-colored = "~2.0.0"
+colored = "~2.1.0"
 rand_distr = "~0.4.3"
-nalgebra = { version = "~0.31.0", features = ["rand-no-std"] }
-itertools = "~0.10.3" 
+nalgebra = { version = "~0.33.0", features = ["rand-no-std"] }
+itertools = "~0.13.0"
 numeric_literals = "~0.2.0"
-poloto = "~3.13.1"
-GSL = "~6.0.0"
+GSL = "~7.0.0"
 float_extras = "~0.1.6"
-clap = { version = "~4.0.27", features = ["derive", "unicode", "wrap_help"] }
-image = "~0.24.3"
+clap = { version = "~4.5.0", features = ["derive", "unicode", "wrap_help"] }
 cpu-time = "~1.0.0"
-colorbrewer = "~0.2.0"
-rgb = "~0.8.33"
 serde_json = "~1.0.85"
 chrono = { version = "~0.4.23", features = ["alloc", "std", "serde"] }
+anyhow = "1.0.95"
 
 [build-dependencies]
-regex = "~1.7.0"
+regex = "~1.11.0"
 
 [profile.release]
 debug = true

mercurial