pyproject.toml

changeset 137
41eca7c39c39
parent 135
45c1a38f8709
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Sun Dec 05 14:40:21 2021 +0200
@@ -0,0 +1,30 @@
+[metadata]
+name = "borgend"
+version = "0.1.0"
+author = "Tuomo Valkonen"
+author_email = "tuomov@iki.fi"
+url = "https://tuomov.iki.fi/software/borgend/"
+
+[options]
+packages = "borgend"
+python_requires = ">=3.8"
+install_requires = [
+    "rumps",
+    "keyring",
+    "PyYAML",
+    "xdg;platform_system!='darwin'"
+]
+app = "borgend/__main__.py"
+
+[build-system]
+requires = ["setuptools", "wheel", "py2app"]
+build-backend = "setuptools.build_meta"
+
+[options.entry_points]
+console_scripts = { borgend = "borgend.__main__:main" }
+
+[options.py2app]
+argv_emulation = false
+plist = { LSUIElement = true }
+excludes = ['wx', 'matplotlib', 'numpy', 'scipy', 'sip']
+

mercurial